Get in touch
Back
Maintenance

Scheduled maintenance

Completed 14 Sep at 08:30pm EEST.

Server Cluster 2
Completed

Maintenance completed

Posted 14 Sep at 08:30pm EEST.
Started

A short service interruption occurred on Server Cluster 2 due to scheduled maintenance. The interruption lasted approximately 3 minutes.
All services are now operating normally.

Posted 14 Sep at 07:00pm EEST.